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1 What is MOBA-NMS? 

MOBA-NMS is a Network Management System used to administer and manage MOBATIME network 
devices. It is designed to handle multiple devices (more than 1000 per network / configuration) of 
different types at the same time. 

 Some key functions are:  

• Automatic device detection  
• Logical device groups  
• Device status / alarm display  
• Sending of device commands  
• Multicast, broadcast and unicast communication  
• Network monitoring  
• Integrated user management  
• etc.  

 
With this application you have the full control over all MOBATIME devices in your network!  

2 Editions 

Since there are different types of network configurations of MOBATIME devices, not each customer 
needs the same set of functionality in his MOBA-NMS installation. Therefore there are these editions 
of NMS:  

2.1 NMS Basic Edition 

The Basic Edition of MOBA-NMS supports the following features:  

• Find single devices with the integrated auto search  
• Configure a single device at the same time  
• Send commands to a device  
• Switch Editor Basic  
• Edit the timezone table of devices  
• Update the firmware of a device  

2.2 NMS Pro Edition 

The Pro Edition of MOBA-NMS supports, additionally to the features of the Basic Edition, the 
following features:  

• Manage and configure multiple devices at the same time  
• Monitor timezones, firmware updates and network time packages  
• Send commands to multiple devices  
• Create multiple user profiles for users with different permissions  
• See the alarm state for multiple devices at a glance  
• Order devices in folder groups  

2.3 NMS Expert Edition 

The Expert Edition of MOBA-NMS supports, additionally to the features of the Pro Edition, the 
following features:  

• Monitor the status (e.g. alarms, warnings) of devices with the MOBA-Device Supervision 
Service (DSS) 
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3 License management 

3.1 Activate a License 

To use MOBA-NMS, you need to activate your installation with a valid license key. You will get your 
license key by email or in the MOBA-NMS Webportal. 

3.1.1 First start 

At the first start, MOBA-NMS asks to open the license manager because there is no valid license. 
Click "Yes" to open the license manager in order to activate your license. When you don't open the 
license manager MOBA-NMS will close itself since you cannot use it without a valid license. 
 
After you opened the license manager, continue with the section "Entering the license".  

3.1.2 Open the license manager 

In order to open the license manager when a valid license is already imported select Settings from the 
menu bar at the top of the program and then click License Manager.  

3.1.3 Entering the license 

To enter your license key, please click on Activate NMS. This will open a dialog similar to this one:  
 

 
Copy your license key from the email or the MOBA-NMS Webportal, paste it into the input field and 
continue by clicking Next. You may have to wait a couple of seconds while the license is being 
checked before the Next button gets clickable.  

3.1.4 Activating the license 

As you click Next in the previous dialog, another dialog will open up. Please choose if you would like 
to activate your installation online over the internet or offline with the MOBA-NMS Webportal. 
To activate MOBA-NMS automatically, select Activate offline and click Next Then click Activate in the 
next dialog to complete the activation of your license. 
 
You can find more information about the offline activation in the section "Manage licenses when 
offline".  

 

A license key can only be used on one system simultaneously. If you need to 
activate more computers, please contact your reseller to aquire additional license 
keys. If you would like to move an activated license to another computer, please 
refer to the section "Move a license to another system". 

3.1.5 System Binding 

As you activate MOBA-NMS with your license, it will bind the license to your computer. If you move 
the application or change your hardware, the binding may get lost. In this case, you should try to 
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activate the license again, and if this fails, contact support. If the current binding is invalid a 
corresponding message is displayed when opening the application. 

3.2 Move a license to another system 

Since a license is only usable on one system simultaneously, you may want to deactivate the license 
on your system and move it to another system.  

3.2.1 Deactivate license 

Important: We recommend to write down your license id before deactivating your license so you can 
find the license key easier afterwards. The license id is displayed in your license manager main 
window. 
 
As a first step to move your license to another system, you'll need to deactivate your license. In order 
to do that, open the license manager and click Deactivate MOBA-NMS. You can now select if you 
would like to deactivate your license online or offline. Please refer to the section "Activate a License" 
to get more information about online and offline actions since activation and deactivation works in a 
similar way.  

3.2.2 Activate license on another system 

Follow the instructions in the "Activate a License" chapter of this manual to activate the now 
deactivated license on another system. If you don't know your license key anymore, log in to your 
MOBA-NMS Webportal account and search for your previously written down license id, which will lead 
you to your license key. 

3.3 Manage licenses when offline 

Sometimes, when your computer does not have an internet connection, you will need to activate your 
license with the offline activation in the MOBA-NMS Webportal.  

3.3.1 Activate license offline 

Proceed according to the "Activate a License" chapter until you see the dialog where you can select 
between Activate online and Activate offline. Select Activate offline and click on Next. You will now 
see two input fields, one of them filled with an activation code:  

 

 

A license can only be deactivated three times, this means that license deactivation is 
deactivated afterwards. If you try to deactivate a license more then three times, you 
are going to be asked if you just want to remove the license from your system since 
it is not deactivatable anymore. If you do so, the license is removed (but not 
deactivated) from your system and you can activate another license on this system.  
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Save this code to a file by clicking on Save file... and transfer it to a computer with internet access 
(e.g. with an USB stick). Then log in to your MOBA-NMS Webportal account and navigate to Offline 
action–>Offline activation. You can now upload your previously created activation code file, which will 
download another file to your computer. Transfer this downloaded file back to your computer with no 
internet access (the computer you want to activate MOBA-NMS on). Load the downloaded file into the 
second input field by clicking the Load file... button. Afterwards, press Activate to activate the license.  

3.3.2 Deactivate license offline 

Deactivating your software when offline works almost the same way as activating it offline.  
 
First, proceed according to the "Deactivate license" section in the "Move to another system" chapter 
until you see the dialog where you can select between Deactivate online and Deactivate offline. 
Select Deactivate offline, click Deactivate and confirm the deactivation of your software.  

 
You can now see a deactivation code, similar to the activation code above. Save this code to a file by 
clicking the Save file... and transfer it to a computer with internet connection. Log in to your MOBA-
NMS Webportal account and navigate to Offline action–>Offline activation.  

 
Then, just load your deactivation code from the tranferred file and upload it. 
Your license is now deactivated.  

3.4 Maintenance licenses 

To get customer support and continous 
updates for the software, you need to 
have a maintenance license. You'll 
normally get a one-year maintenance 
license with your standard MOBA-NMS 
license. Afterwards, you can buy a 
maintenance license extension through 
the sales company responsible for you.  

 

The activation code which is generated by MOBA-NMS is unique for each computer. 
This means that you must create the activation code on the same system which you 
want to activate MOBA-NMS afterwards (i.e. you cannot use the same activation code 
to activate two different installations of MOBA-NMS).  
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3.4.1 Remaining maintenance license duration 

You can see the remaining time of your maintenance license in the license manager (open via 
Settings and then License manager) on the bottom of the window:  

3.4.2 Extending your maintenance license 

If you buy a maintenance license extension, you will get a maintenance key similar to the one you got 
for activating MOBA-NMS. To activate the new maintenance extension open the license manager and 
click Extend maintenance period. Then, just follow the instructions from the "Activate a license" 
chapter, since both processes are the same.  

 
 

After you activate a maintenance license, it is being bound to your activated standard 
license. You will not be able to unbind it! 
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4 Views 

4.1 NMS Basic Main Window 

The application main window of the basic edition consists of three parts: 
 

1. Menu / Toolbar 
2. Properties / Configuration View 
3. Additional Views 

 

 

4.1.1 Menu / Toolbar (1) 

All functionalities provided by MOBA-NMS Basic are accessible over the menu or toolbar. Some 
functions are not available as long there is no device opened.  

4.1.2 Properties / Configuration View (2) 

The properties view is described in the help topic 4.2.3 Properties / Configuration View (3). 

4.1.3 Additional Views (3) 

This part of the application can contain additional features like error monitors this are monitoring and 
error log views at the moment.  
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4.2 NMS Pro Main Window 

The application main window consists of 
four parts: 

1. Menu / Toolbar  
2. Device View  
3. Properties / Configuration View  
4. Additional Views  

4.2.1 Menu / Toolbar (1) 

All functionalities provided by MOBA-NMS 
are accessible over the menu or toolbar.  
Based on the current selection in the device 
view, some functions are disabled. For 
example, if no device is selected the menu 
entry Edit -> Open device Configuration is 
not available. 

 

4.2.2 Device View (2) 

The Device View is the main part for managing 
MOBATIME network devices. Here you have the 
possibility to add supported network devices, group them 
to logical units, save the created configuration to file, load 
existing files, open device configuration or send device 
commands.  
 
In this view, the key functions are also available over the 
right click context menu. (The same functions those are 
available over the menu or toolbar.)  
By selecting one device, the property view shows an 
overview page with the device configuration and status.  

4.2.2.1 Device Groups 

Device groups are used to arrange the devices to logical 
units, so that the configuration represents the real 
infrastructure. 

4.2.2.2 Group settings 

Each group can hold default settings that are used for all 
contained devices and child groups. Currently there can 
be set the default device username / password and the 
domain name. These settings are used for all devices 
that don't have own values defined. 

 

Example: If a device requires the username and password, but there is no authentication information 
saved in the password manager, the default values defined by the group settings will be used.  
 
To open the settings dialog, select the menu entry Edit -> Group Settings... 
Groups with changed settings are marked with the following icon:  
 

 

Device username and password are stored in the password manager and not in the 
configuration file (*.mnms)!  
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4.2.2.3 Error and Alarm icons 

Devices and groups with errors and/or alarms automatically have a corresponding icon: 
 

 

Device (here movement) with error(s) 

 

Device (here movement) with alarm(s) 
 

 

Group containing device(s) with error(s) 

 

Group containing device(s) with alarm(s) 

 

Group containing device(s) with error(s) and alarm(s) 

4.2.3 Properties / Configuration View (3) 

This view shows the information 
about the current selected entry in 
the device view. If a device is 
selected, an overview page with 
configuration and status 
information is shown. If a group is 
selected, the page shows an 
overview over all contained 
devices.  
 
By clicking on the Open 
Configuration button, the 
Properties View gets replaced with 
the Configuration View that shows 
detailed device information and 
provides controls to change the 
configuration. (Note: Not all 
devices have the same 
configuration values. For this 
reason, the configuration view can 
have different content based on the 
device type and version.) 
 

 

4.2.4 Additional Views (4) 

This part of the application contains multiple views with additional functionalities. These are 
monitoring and error log views at the moment.  
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5 Frequently used functions 

5.1 Scan for devices 

To configure MOBATIME devices you will need to perform a network search for these devices. To do 
so, you can either use the device auto scan (recommended), the scan device wizard or the manual 
device configuration.  

5.1.1 Device auto scan 

The easiest way to find MOBATIME network 
devices is to use the device auto scan. The 
device auto scan is the recommended way to 
search devices. If you have to configure further 
settings of the search, refer to the next section of 
this help page.  

1. To start the wizard click the Auto Scan 

For Devices ( ) button or the menu 
entry Edit -> Auto Scan For Devices. You 
should now see the device auto scan 
window.  

2. Start the search for devices by clicking 
the "Start scan" button on the left side of 
the window. It will take some time until 
the search has finished. 

 

3. If you are using the pro edition, you can now add these devices to the device view. Refer to 
"Add device(s) to Device View" to learn more.  
 
If you are using the basic edition, you can select one of those devices to open its 
configuration screen.  

5.1.2 Scan device wizard 

The scan device wizard basically works like the device auto scanner, but allows more configuration: 
Before you search for devices, you can set the mode of communication and which type of devices 
should be found.  

• Multicast: Supported by most MOBATIME end devices (clocks) but not by the servers.  
Important: Multicast communication has to be enabled in your network!  
For more information contact your network administrator.  

• Multicast IPv6: See Multicast, but IPv6 instead of IPv4 is used for communication.  
Important: A valid IPv6 configuration is required.  
For more information contact your network administrator.  

• Broadcast: Supported only by newer devices for initial network configuration. For IPv6 
networks, a link-local search can be performed via the address ff02::1. To do that, select the 
corresponding check box and configure the local IPv6 interface in the application preferences.  

• Unicast: Supported only by newer devices running in Unicast mode.  
• Unicast IPv6: See Unicast, but IPv6 instead of IPv4 is used for communication.  

Important: A valid IPv6 configuration is required.  
For more information contact your network administrator.  
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5.1.3 Add device manually 

If you have only one device and know all needed information like MAC or IP address, there is also a 
wizard which helps you to find it manually.  

1. To start the wizard click the Add device ( ) button or the menu entry Edit -> Add Device.  
2. Choose the device type you have.  
3. On the next page you can either select multicast or unicast communication.  

o Multicast communication: Select the multicast group and enter the device MAC 
address. Important: Multicast communication has to be enabled in your network!  
For more information contact your network administrator.  

o Unicast communication: Enter the device IP address.  

 

Not all devices supports all communication modes. Unsupported modes are disabled!  

5.2 Add Device(s) to Device View 

If you are using the Pro edition of MOBA-NMS, 
you can use the device view. This is a list of 
managed devices which is used to give the 
user an easy access to his devices.  
 
You can scan for devices by following the steps 
of the "Scan for devices" chapter.  
 
By default, all new devices shown in the table 
are marked to be added to the device view. 
Unmark those ones you want to be ignored.  
 
Already known devices are grayed out. 
However, you can mark them and activate the 
check box Refresh existing devices in the 
device view to refresh / update the devices 
connection information.  
 
Select how the new devices should be sorted in the device view and click the Finish button to close 
the wizard. All selected devices are now available in the corresponding predefined root group. (Based 
on the device type. For example Movements or Master Clocks.) 

5.3 Change Device Configuration 

To open the device configuration view which allows you to edit the device settings, either click to the 
Open Device Configuration ( ) button, select the menu entry Edit -> Open Device Configuration, 
double-click to the device in the device view or click to the Open Configuration button in the 
properties view.  

 
Example of the NBU 190 movement  
General Settings tab  
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The configuration view usually consists of 
multiple tabs. The Overview tab shows the key 
configuration values and is read only. Further 
tabs like General Settings depends on the 
device type and allow you to change device 
specific settings.  
 
After changing the configuration click to the Save 
button to send the new values to the device. 
After a short wait for the device restart a 
message box will appear to inform you if the 
configuration was sent successfully or not. 

 

 

If you change the device network settings like IP address, subnet mask, etc. to an 
address that is not reachable by MOBA-NMS, the connection to the device will be lost! 

5.4 Send Device Commands 

Most of MOBATIME devices support device commands like the 
12:00 Position command for network movements. To send such 
commands, use either the right click context menu in the device 
view, click to the Device Commands ( ) button or select the 
menu entry Edit -> Commands. In each case, a new sub-menu 
with all available commands (for the current selection) will 
appear. Click to the desired entry and wait for the status dialog to 
see if the command was send successfully to the device. 

 

 
Note: Not all devices have the same commands! The sub-menu shows only commands supported by 
all selected device types.  

5.4.1 Group commands 

You also have the possibility to send commands to a 
group of devices. This is done the same way as sending 
only one command but with multiple devices or device 
groups selected. Note that the sub-menu will only show 
commands supported by all selected device types. (If you 
have different device types in one group only commands 
supported by all devices will be available.)  

5.4.2 Advanced group commands 

If you want to send a specific command (that is 
supported by only one device type) to a group containing 
different types, the command will not be available in the 
sub-menu. In this case, the Advanced Device Group 
Commands dialog can be used. In this dialog you have 
the possibility to send group commands to all devices 
that are from the same type. To open the dialog, click to 
the Advanced... command sub-menu entry that is shown 
if multiple devices or a device group is selected.  

 

The dialog shows all device types at the left. Select the type you want and all available type specific 
commands will be shown at the right. 
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5.5 Manage Devices 

Devices shown in the device view can be sorted and grouped to 
logical groups for easier management.  

5.5.1 Create device group 

Click on the Create new group ( ) button or select the menu 
entry Edit -> New Group and enter the name to create a new 
logical device group.  
 
Note: New groups can only be created if an already existing group 
is selected. If no group was created before, select a predefined 
root group. (For example Movements or Master Clocks.)  

5.5.2 Move and sort devices / groups 

Devices and groups can be moved and sorted by Drag and Drop. 
To do this, select one or more devices or groups and drag them to 
the destination group at the desired position. Please note that 
entries can only be moved within the same predefined root group. 
(For example, it's not possible to move a movement device or 
group into a group of master clocks, or vice versa.)  

 

5.6 Save / Load Configuration 

The content of the device view can be saved to a configuration file and loaded again later. For this, 
the menu entries File -> Save Configuration and File -> Load Configuration are available.  
 
5.6.1 Status refresh after load 

After loading a configuration from file, MOBA-
NMS can update the status / alarm information 
of all loaded devices automatically. It's 
recommended to run the update after each 
load to keep the device view synchronized 
with the devices.   
 
By default, a dialog (see image) will appear that let you decide if the update should be run or not. If 
the Don't show again checkbox is set, your answer will be saved for future loads. (This behavior can 
be changed in the application preferences.)  

5.7 Status / Alarm Refresh 

The device view is a static list / tree that hold only some basic information (like status, alarms, MAC, 
IP address, etc.) for each device. If the configuration was loaded from a file or not refreshed for a 
longer time the status / alarm information don't represent the real device state.  
 
To refresh the information select one or more devices (or device groups) and click to the Refresh ( ) 
button or select the menu entry Edit -> Refresh Device Status / Alarm. If you select a group that 
contains subgroups, the devices of all sub groups will be updated as well (Recursive). 
 
Note: The status / alarm information is updated automatically if you open the device configuration by 
double-click to the device or click to the Open Configuration button in the properties view.  
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5.8 Update Device Firmware 

To update the firmware of one or more devices 
(with the same type) click to the Firmware 
Update... command that is shown in the 
command sub-menu.  
 
In the Device Update dialog, select the new 
firmware file and click to the OK button. The 
update will start immediately. 
 

 

 

MOBA-NMS starts an internal 
TFTP-Server (with default port 69) 
from which the device(s) can 
download the new firmware. Make 
sure that no firewall blocks the used 
port!  

 

 

Don't close MOBA-NMS while a firmware update is running! 

5.9 Edit Connection Settings 

If the network configuration of a device, that is 
loaded in the device view, is changed outside 
MOBA-NMS (e.g. by DHCP server, telnet, DIP-
Switches, etc.), the connection to the device gets 
lost. In this case, you can either delete the 
device from the device view and add it again or 
change the connection settings manually.  
 
To change the settings manually, open the 
connection settings dialog by selecting the menu 
entry Edit -> Edit Connection Settings... or 
clicking to the corresponding entry in the right 
click context menu ( ).  
 
The connection settings dialog is the same as 
used to add a device manually to the device 
view. 
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6 Monitoring 

6.1 NTP Monitor 

The NTP monitor records all NTP packets received on one or more multicast groups. (Packets sent 
out by a master clock like the MOBATIME DTS.)  
 

 

Make sure that no other application is listening to the default NTP port 123!  
 

 

For each recorded packet the following information is available: 
 
Status: OK if the packet was read correct, otherwise error description. 
Group: The multicast group 
Source IP: IP of the NTP server 
Received (PC time): The receive time of the packet (PC clock) 
Transmitted (Server time): The server transmit time (read-out from the packet) 
Ver.: NTP packet version 
Stratum: The stratum level 
Ref.: Server reference clock (e.g. GPC, DCF77, ...) 
Raw Data: The received raw data 
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6.2 Time Zone Monitor 

The time zone monitor records all MOBATIME Time Zone Packets received on one or more multicast 
groups. (Packets sent out by a master clock like the MOBATIME DTS.) One time zone packet 
contains information like the local offset, daylight saving time, etc.  

 

For each recorded packet the following information is available: 
 
Status: OK if the packet was read correct, otherwise error description. 
Group: The multicast group 
Source IP: IP of the server 
Received: The receive time of the packet (PC clock) 
Ver.: Time zone table version 
No.: Number of the time zone entry 
DST Information: Short description of the daylight saving time configuration 
Offset [min]: Local offset in minutes 
Raw Data: The received raw data 

6.3 Status Monitor 

With the status monitor you have the possibility to update the device status and alarm information in a 
user-defined interval. For each update run the monitor will log detailed status and alarm information.  
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6.3.1 Start monitoring 

1. First select the device group(s) you want to monitor. To open a dialog for the group(s) 
selection click to the Select... button.  

2. Select the update interval.  
3. Click to the Start button.  

 

All device view operations will be disabled while this monitor is running!  

 
For each update run the following information is available: 
 

Overview Overview with date / time, count of devices without errors or alarms, count of devices 
with error(s) and count of devices with alarm(s) 

Error: Shown only if an error occurred and the update was not done 
Status: The device status at the moment the update was done 
Alarm(s): Device alarm(s) at the moment the update was done 
 
Note: Detailed information is shown only for devices that are in alarm or error state. If you want to 
display all devices set the "Show all devices" checkbox. 
 

• Right click to a device in the log and click to "Show status update history" to display the update 
history for only one device.  

• Right click to a device in the log and click to "Select device in device view" to select the device 
in the device view.  

 

6.4 Firmware Monitor 

The firmware monitor gives you the possibility to restart a recently failed firmware update procedure 
(e.g if the network connection was interrupted during update).  
 

 

The monitor only detects devices which are in the same network during the origin 
update command was sent.  
MOBA-NMS must also be available under the origin ip address.  
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For each recorded packet the following information is available: 
 
Source IP: IP of the device 
Firmware File: Requested Firmware 
Raw Data: The received raw data 

6.4.1 Start the update 

• Right click on an entry in the list.  
• Chose firmware update. The firmware choose dialog will be shown. 

6.5 Additional functions 

The list of recorded packets can be exported, imported or deleted.  
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7 Tools 

7.1 Switch Editor Basic 

7.1.1 What is Switch Editor Basic? 

With the basic version of Switch Editor, switching programs for MOBATIME devices such as DTS 
4801, DTS 4802, DTS 4132 or ETC for example can be defined with simple and familiar tools. For this 
purpose up to four switching channels with different week programs can be allocated.  
 
An overview of some important functions:  

• Up to four switching channels definable  
• Switching commands with fixed start and end times or signals (1 – 90 sec) are supported  
• Calendar view for definition of the switching commands  
• Easy to edit the switching commands with Drag & Drop  
• Copy & Paste function  
• Definition of exception days  
• Table view / printout  
• etc.  

The Switch Editor Basic software is available as an independent application or integrated in MOBA-
NMS.  

7.1.2 Main Window 

The main window of the application consists of 
four parts: 

1. Menu / toolbar  
2. Channel selection and description  
3. Calendar view for display of switching 

commands / signals  
4. Zoom for calendar view  

7.1.2.1 Menu / toolbar (1) 

All Switch Editor Basic functions are accessible 
via the menu. Frequently used commands are 
also directly available in the toolbar.  

 

 
 
NB: 
Some commands are dependent on the current selection in the calendar view, therefore for example 
the menu item Edit -> Edit entry... is only available if an entry is also selected in the calendar view.  

7.1.2.2 Channel selection + description (2) 

Selecting channels 1 to 4 determines for which channel the switching commands are displayed in the 
calendar view. When the current selection is changed, the calendar view display is automatically 
updated. A user-defined designation can also be set for each channel under Channel description.  

7.1.2.3 Calendar view for display of switching commands / signals (3) 

Display of all switching commands / signals for the currently selected channel. Thus the calendar 
always includes all weekdays (Mon – Sun) irrespective of the date. (As for each channel a week 
program is defined that is always repeated.)  
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7.1.2.4 Zoom for calendar view (4) 

Adjustment of the zoom setting for the calendar view.  

7.1.3 General Information 

A switching program is used to control the switching statuses of the separate channels on 
MOBATIME devices with MOBALine and switching function support. Channels 1 to 4 are defined in 
this way with Switch Editor Basic.  
 
For each channel a program known as a week program is created. This determines on which days of 
the week and at what time the channel is switched on or off. These switching commands can have 
either a fixed start and end time or be defined as signals with a power-on period of 1 to 90 seconds.  
 
Week programs are repeated indefinitely for each channel, except for when exceptions are defined for 
separate days.  

7.1.3.1 Presentation in Switch Editor Basic 

In Switch Editor Basic week programs and switching commands are shown as follows:  

 
The image shows that the switching commands are arranged like appointments in a calendar.  

7.1.3.2 Data management 

Switching programs can be stored in *.swprog files and loaded again. Thus all information such as for 
example channel designations, comments on the switching entries etc. is stored.  
 
For the devices themselves the switching program is used in the form of a *.prg file. In this file format 
only the effective switching commands for each channel are stored; all other information such as 
designations etc. is not included.  
 

 

Never delete *.swprog files, because only these files contain all information about a 
switching program! (New *.prg files can also be created from them.)  
 
*.prg files can only be used for the devices and can no longer be directly altered!  
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7.1.4 Creating, Editing or Deleting Entries 

Essentially the switching entries can be viewed like appointments in a calendar. As is usual for 
example with other programs with calendar views, the separate entries can be moved using Drag & 
Drop, their duration can be altered or they can be copied and added using Copy & Paste.  

7.1.4.1 Creating a new entry 

To create a new entry there are several 
options:  

• Select the menu item Edit -> New 
entry...  

• Click on the toolbar button:  
• Right click in the calendar field 

(on the desired day and the start 
time) and select the context 
menu entry New entry...  

• Double click in the calendar field 
(on the desired day and the start 
time)  

A dialog is then displayed (see image) in 
which the settings of the new entry are 
defined. All setting options are divided 
into three groups:  

 

 
 
General settings 
 
Here a user-defined description can be entered and the type ("Fixed start and end time" or "Signal") 
can be selected.  
 
Start / end time 

• Start: definition of day of week and time when the channel is switched on.  
• End: definition of day of week and time when the channel is switched off. (Only available if the 

type "Fixed start and end time" is selected.)  
• Duration [s]: Signal duration in seconds (Only available if the "Signal" type is selected.)  

Switching entries with fixed start and end times can also 
be executed over several days. However they have some 
restrictions which are described under „Execution Over 
Several Days“.  
 
Additional execution day(s) 
Switching commands can also be run on several 
weekdays at the same time. Here the individual days are 
selected. The day of week defined as the start day is pre-
selected and cannot be altered. 
  
Tip: By clicking on the Workdays or Weekend button all 
working days and weekend days respectively are 
automatically selected.  
 
The additional execution days are tagged as appropriate 
in the calendar view. 
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7.1.4.2 Editing an entry 

To edit an existing entry the same dialog is used as for its creation. To open this, the same options 
are also available as for its creation: menu, toolbar, right click context menu or double click. Please 
note that the appropriate entry must also be selected.  
 
If only the start time, duration or day of the week is altered, the entry can be moved using Drag & 
Drop. To do this select the entry at the appropriate location and drag it to the new position (see 
image).  

1. Drag the upper edge to alter the start time only.  
2. Drag the lower edge to alter the period (end time) only.  
3. Drag the whole entry to alter the start time or the day.  

NB: 
With signals, the duration cannot be altered using Drag & Drop!  

7.1.4.3 Deleting an entry 

To delete an entry, the same options are available as for editing: menu, toolbar or right click context 
menu. The [DEL] (Delete) button can also be used. Please note that the appropriate entry must also 
be selected.  
 

7.1.5 Additional Execution Days 

Switching entries with fixed start and end times or signals may also be executed on several weekdays 
at the same time (and for the same duration). These entries are marked in the calendar view with an 
icon ( ) and indicated accordingly on the defined days. When moving an entry using Drag & Drop, all 
matching entries are also taken into consideration.  

 

The image shows an entry that sets the channel to "on" on Monday from 02:00 to 04:00. This is also 
executed on Tuesday and Wednesday at the same time. 

7.1.6 Execution Over Several Days 

The start and end time of an entry does not 
necessarily have to be on the same day, and so 
a channel can be switched on over several days.  
 
The following image shows an example, in which 
the channel is switched on from Monday at 09:00 
to Thursday at 15:00. 
 

 
 

Entries that stretch over several 
days cannot be moved using Drag & 
Drop. It is only possible to alter the 
start and end time. Likewise no 
additional run dates can be defined. 
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7.1.7 Conflicts 

Within a week program the entries must not overlap. If an 
overlapping is discovered when creating or editing, there is a conflict 
and the procedure cannot be continued. In this case the start or end 
time must be adjusted accordingly.  
When moving entries using Drag & Drop, conflicts are indicated 
when the moved entry is shown in grey and with an "X" (see image). 
In this case the entry cannot be placed and returns automatically to 
the original position.  

 

 

7.1.8 Exceptions 

If on a particular day or over a 
longer period of time no switching 
commands are executed, 
exceptions can be defined for each 
channel. These exceptions always 
have a fixed date (or a date range) 
with the effect that on these days 
on the relevant channel no 
switching commands are executed 
and the channel always remains 
switched off. Likewise longer 
switching commands which extend 
for example over several days are 
interrupted by exceptions. 
 
The dialog for the definition of 
exceptions is opened with the 
menu item Options -> Define 
exceptions... (see image).  

Here new entries can be defined for each channel or already existing ones can be edited or deleted. 
Every entry therefore has a fixed from and to date and optionally a user-defined description. If an 
exception is defined for a single day, the from and to dates must be defined on the same day.  
 
In this example two exceptions are defined:  

• 10.09.2012  
• 17.09. - 20.09.2012  

7.1.9 PRG File Generation 

Switching programs are downloaded to the devices in the form of *.prg files. In order to generate 
these, the switching program must simply be saved in Switch Editor Basic (menu item File -> Save 
(and create PRG file.)). During the storage procedure a *.prg file is automatically generated in the 
same folder and under the same name alongside the *.swprog file.  

7.1.10 Table / Printview 

All switching commands can be presented in a table and also printed in the same form.  

7.1.10.1 Table view 

The table view is opened with the menu item Options -> Table view... or directly using the toolbar 
button . The exceptions for each channel are also listed beside the switching commands.  
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7.1.10.2 Print view / print preview 

The print view is opened either from the table view (Print... button), the menu item File -> Print... or 
using the toolbar button . As in the table view, the defined exceptions are also listed in the print 
view. In addition only individual channels can be selected for printing. (Channels for which there are 
no entries are shown in grey and cannot be selected).  

7.1.11 Application preferences 

7.1.11.1 General 

• Application language 
Select the preferred application language. By default, the language will be switched 
automatically based on your operating system language. (Only if the language is available, 
otherwise English will be used.) 

7.1.11.2 Editing Behavior 

• General settings 
o Default signal length for new entries [s]: 

The signal length determined here is used as default value when creating new entries. 
o Don't show delete confirm dialog box: 

If this option is selected, no confirmation dialog is displayed when entries are deleted. 
(Entry is directly deleted without request.)  

7.2 Time Zone Editor 

MOBA-NMS contains an integrated time zone editor that lets you create and edit user defined time 
zone definitions. This is usually only necessary if the time zone you need is not already listed in the 
default time zone definitions provided by MOBATIME.  
 
MOBATIME provides 65 default time zone definitions (no. 0 - 64). These definitions cannot be 
changed / deleted and are updated together with MOBA-NMS automatically. The definitions 80 to 99 
are free configurable.  
 
To open the editor, select the menu entry Tools -> Time Zone Editor.  

 

7.2.1 Where are time zone definitions used? 

In MOBA-NMS created time zone definitions can be used for all MOBATIME devices with time zone 
table support. Example: Set user defined time zone(s) to NBU 190, SEN / SAN 40 movements or any 
DTS masterclock / timeserver.  
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7.2.2 Where are the time zone definitions stored? 

MOBA-NMS stores user defined time zone definitions in the application workspace folder. 
(<install_dir>/workspace/usersn.tbl) The file usersn.tbl is a " MOBATIME Time Zone Table File" (also 
called Season Table File) that can also be used for other devices like ETC, CTC, etc. You can use the 
export function (see Import / Export) to export the file to a user defined location.  
 

 

Some devices (like DTS timeservers / masterclocks) have integrated time zone 
definitions. (With own usersn.tbl file.) If you open the time zone editor out from a device 
configuration view (see Change Device Configuration), the editor loads the definitions 
directly from the device and don't use the MOBA-NMS internal files.  
 

7.2.3 Time Zone Definition 

One time zone definition consists of the following items:  
 

Item Description 

Number 
Definition number (80 - 99 for user definitions).  
Important: Keep numbers continuous and replace not used entries with the 
UTC definition! 

Name Display name (max. 30 characters, e.g. "Central Time") 
Local offset Local time offset in minutes (offset UTC <-> winter time) 

DST switch mode Mode of the Daylight Saving Time (see chapter Daylight saving time (DST) 
below) 

Season offset Time offset during daylight saving time in minutes (offset winter time <-> 
summer time) 

7.2.4 Daylight saving time (DST) 

There are three possibilities / modes to configure the Daylight Saving Time (DST) switch for your time 
zone:  

• No Daylight Saving Time 
No DST switch configuration. Local offset is used only.  

• Exact date / time 
The DST is switched only once at the exact user defined date / time. 
Important: The date / time must be adjusted every year!  

• Estimated / Calculated date 
The DST is switched every year at the configured weekday, month and exact time. 
There are different possibilities for the weekday calculation:  

o First specified day of the month  
o Last specified day of the month  
o Second specified day of the month  
o Last but one specified day of the month  
o Third specified day of the month  
o Last but two specified day of the month 

  

http://127.0.0.1:50989/help/topic/com.mobatime.nms.help/html/time_zone_editor/time_zone_def.html?cp=0_4_1_0#dst
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7.2.5 Create new Definition 

Follow the steps below to create a new user defined time zone definition:  

1. Open the Time Zone Editor  
2. Click to the New... button  
3. Select either the radio box "Empty" to create an empty time zone definition or "Use existing 

definition as template" to create a new definition based on an already existing one 
(recommended). 

 
4. Set the time zone name, local offset and daylight saving time configuration according to the 

definition described in chapter Time Zone Definition. 

 
5. Close the dialog by clicking to the OK button  
6. Click to the Save button to save the new created definition to the MOBA-NMS internal file  

7.2.6 Edit Definition 

To change an already existing user definition, select it in the table and click to the Edit... button. Set 
the configuration according to the definition described in chapter Time Zone Definition.  
 

 

Default time zone definitions provided by MOBATIME (no. 0 - 64) cannot be changed!  

7.2.7 Import / Export 

User defined time zone definitions can be imported or exported. The import function can be helpful if 
you have already a time zone table file (also called season table file) created by other software like 
CTCW and want to use it in MOBA-NMS. The export function is used to create a backup or save the 
definitions to a *.tbl file that can be used also for other MOBATIME products like ETC, CTC, etc.  
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7.2.7.1 Import 

Click to the Import... button and select the *.tbl file to load.  

 

All existing definitions will be overwritten! 

7.2.7.2 Export 

Click to the Export... button and set the target *.tbl file for the export.  

7.3 Password Manager 

Some devices (like DTS masterclocks / timeservers) 
need a username and password for the 
communication / configuration. MOBA-NMS will ask 
you for the device password with an appropriate 
dialog (see image) each time you try to open the 
configuration. 
  
In this dialog, you have the possibility to save the 
username and password by activating the check box 
Save username and password in the password 
manager. In this case, your entered data will be 
saved in the MOBA-NMS internal password 
manager for future use. 

 

7.3.1 Manage Saved Entries 

To show and edit the saved username / 
password entries, open the Password 
Manager by selecting the menu Window 
> Password Manager.... In the Password 
Manager dialog you have all information 
about saved usernames / passwords and 
can edit or delete several entries.  
 
Explanation of the table content:  

• Category: Password category. "Master 
Clocks" or "Slave Clocks".  

• Password type: Type of the password 
entry. e.g. SNMPv3, Telnet, SSH, etc.   

• Device / Identifier: Name and identification (usually MAC address) of the corresponding device. 
(Note: If the device is no longer in the device view, only the identifier is shown.)  

• Username: The device username. 
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8 User Management 

MOBA-NMS provides an integrated user management. To administrate the users and access rights 
select the menu entry Window -> User Management.  

8.1 Create new User 

To create a new user, open the user management 
dialog by selecting the menu entry Window -> User 
Management... and click to the New... button. Enter 
the username, first name and last name and select 
all write rights the new user should have. Click to 
OK and then to the Change password... button to 
set the initial password. 
  
Note: By default, all users have read right to all 
parts of the application. In some cases, that means 
that a dialog or view can be opened read only (like 
the device configuration) and other cases that a 
specific function is not available (like the device 
commands). 
 
 

 

8.1.1 User rights 

Name Allows to… 

Device view (Add / delete devices, create / 
delete groups, etc.) … create and remove device and device groups. 

Device configuration (write configuration to 
devices) … write configurations to devices. 

Device commands (Send commands to 
devices) … send commands to devices. 

User preferences … access the user preferences for this user. 
Administrator/User default preferences (Only 
for administrators) … access the administrator/default user preferences. 

User management (Only for administrators) … access the user management panel. 
Application update (Only for administrators) … check for and carry out application updates. 
License manager (Only for administrators) … manage the application license. 
Time Zone Editor …. use the Time Zone Handler. 
Switch Editor Basic … use the Switch Editor Basic. 

 

8.2 Change Password 

The password of the current user can be changed by selecting the menu entry Window -> Change 
Password... 



© MOBATIME 30 / 36 801225.02 
 

9 Application Preferences 

The MOBA-NMS application preferences are defined in two layers. The first layer contains the 
administrator and user default preferences. These apply to all users and are stored in the application 
directory. In the second layer, each user can define individual settings (with the corresponding access 
right). In this case, the presettings of the administrator will be overwritten.  
 
The administrator and user default preferences are located under the menu entry Settings -> 
Administrator / User Default Preferences. Important: Edit these settings only as system administrator 
with local administrator rights!  
 
The user preferences are located under the menu entry Settings -> User Preferences. Please note 
that not all administrator settings can be overwritten by the user. 

9.1 General 

Description of the General preference page values.  
 
Application language  
Select the preferred application language. By default, the language will be switched automatically 
based on your operating system language. (Only if the language is available, otherwise English will be 
used.)  
 
Application startup  
Select the actions that should be performed at the application startup.  
 
Refresh device status / alarm information after load from configuration file  
Set whether the status / alarm information should be refreshed automatically after a configuration was 
loaded from file.  
 
Device configuration view  
An open properties or configuration view updates the device information in a predefined time interval. 
You can set this interval in minutes or disable it by setting the value to 0. 
 
Show information message after configuration was successfully sent to device 
Defines whether a message is shown after a configuration is sent to the device. 
 
Lock configuration files to prevent multi-user conflicts 
Defines if the configuration files should be locked after loading them to prevent  
conflicts when multiple users open the same configuration file. 

9.2 Network 

Description of the Network preference page values.  

9.2.1 Communication Mode 

Select the preferred mode you want to use for the device communication. The default value is 
Multicast and unicast (recommended). In this case, multicast is used for the auto scan and for 
devices that have no unicast support. For devices with unicast support the mode will be switched 
automatically to unicast.  

 

Not all devices support unicast communication! Change this value to Unicast only if you 
have no multicast devices to manage.  
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9.2.2 Multicast / Broadcast settings 

9.2.2.1 Interface for multicast / broadcast communication 

The multicast / broadcast communication is possible on one network interface only. By default, 
MOBA-NMS uses the interface selected by the operating system. (Option System priority / System 
default.) You can change this setting if the default selection is wrong or you want to bind the 
communication to one specific interface.  
 
Important: For IPv6 link-local scans there has to be the link-local address of the computer selected.  

9.2.3 Communication settings 

9.2.3.1 Default timeout 

Set the default response timeout that should be used for the communication. Increase this value if you 
have trouble to connect to devices because of slow network connection.  

9.2.3.2 Resolve host names (DNS) 

If this option is enabled, MOBA-NMS tries to resolve host names by DNS to get the device IP 
addresses. If the host name cannot be resolved, the stored IP addresses will be used. (Same 
behavior as if this option is disabled.)  

9.2.3.3 Default domain 

Some devices have a host name but no domain name saved. For this reason, a default domain name 
can be configured. This is used to resolve the IP address if the option "Resolve host names (DNS)" is 
enabled.  

9.2.4 FTP transfer mode 

Select the preferred FTP data transfer mode you want to use. The default value is Passive 
(recommended).  

 

Please make sure that the port 21 is not blocked by a firewall! The Active mode requires 
additionally the port 20 to be open.  
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10 Usage of the DSS 

If you are using the Expert edition of MOBA-NMS, you can use the MOBA device supervision service. 
This help page provides information on how to define the devices which should be supervised by the 
DSS. For further information about installing and managing the service itself, please read the manual 
which is provided along the DSS.  

10.1 Add/remove devices from supervision 

To define which devices should be 
supervised, open the MOBA-DSS 
configuration page within MOBA-NMS 
and select the "Supervision" tab on 
the bottom of the page. 
 
You can now see the a list of 
available devices which consists of 
devices which are already supervised 
by the DSS and devices which are in 
the device list of your MOBA-NMS. 
 
To supervise or unsupervise a device, 
select a device from the "Available   
devices" list and click the "Supervise" or "Un-supervise" button which are located to the right of the 
list. 
 
If you want to supervise a device which is not yet in the "Available devices" list, add the device to the 
MOBA-NMS device list and click the "Reload table" button. Important: Devices supervised by DSS 
must send SNMP traps to the DSS, otherwise an alarm like "Maximum alive trap time expired" 
is going to be shown.  

10.2 Defining the severity of alert types 

Alerts can have different levels of severities:  

• Alert Handle an alert as a normal, high-level alert.  
• Warning Sets the alert as a lower-level, less important 

warning.  
• Ignore Ignore and do not handle the alert when it 

occurs.  

The severity of an alert can be defined per device. To set 
the severity of an alert for a device, select a device with the 
corresponding device from the "Available devices" list and 
click the "Severity table" button, which opens a new   
window. In this window, you see a list of all alert types for this device. To change the severity of an 
alert type, select the corresponding entry from the list on the left hand side, then choose the new 
severity level with the select box in the "Controls/actions" area.  
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10.3 Managing individual parameters 

For each device, you can define additional SNMP parameters which are supervised and written into 
the database each time the service is updating the status of the device. Each additional parameter 
consists of an OID (identifying number, can be found in the .MIB file) and a name/description. 
You can see a list of all parameters configured for a device by selecting the respective entry for the 
device from the "Available devices" list. The parameters will be listed in the "Parameters of the 
selected device(s)" section.  
 
To add a parameter, select 
the device you would like to 
add the parameter to, and 
click the "Add" button in the 
"Parameters of the 
selected device(s)" section. 
 
Afterwards, fill in the 
required information in the   
dialog which has opened. To edit a parameter, click the "Edit" button instead. 
 
To map existing parameters to other devices, select all the devices you want to map the parameters 
to from the "Available devices" list (select multiple entries by clicking while holding the Ctrl key on 
your keyboard), then select the parameters you want to map from the parameter list. Finally, click the 
"Map selected" button. 
 

11 Application Error Log 

Sometimes it can be necessary to have a look into the application error log to be able to troubleshoot 
specific problems. To do this, select the menu entry Window -> Show View -> Error Log. The log will 
be loaded in the additional views part at the bottom. 
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12 Technical Information 

This chapter contains some technical information about MOBA-NMS that can be helpful to 
troubleshoot different problems.  

12.1 System Requirements 

Operating 
system: 

Windows XP / Vista / 7 / 8 / 10, Linux Version (32/64bit) on request 

Hardware: 
1 GHz processor, 1024MB RAM, 1024x768 (or higher) resolution, network (LAN) 
connection 

12.2 Runtime environment 

MOBA-NMS requires Java Runtime Environment (JRE) version 1.8 or newer.  
Download from: http://www.java.com/en/download  

12.3 Used network ports 

Port Service Protocol Mode Open on... Usage 

20 / 
21 FTP TCP Unicast device DTS devices file transfer (if SFTP is 

not supported by device) 

22 SSH TCP Unicast device DTS devices SSH communication + 
SFTP file transfer  

69 TFTP UDP Unicast, Multicast MOBA-NMS Network slave clocks firmware 
update 

80 HTTP TCP Unicast remote 
server MOBA-NMS software update 

123 NTP UDP Unicast, Multicast device / 
MOBA-NMS 

DTS devices time requests / NTP 
monitor 

161 SNMP UDP Unicast device DTS devices communication 

65532 MOBACOMM UDP Unicast, Multicast, 
Broadcast device 

Network slave clocks 
communication. 
Broadcast device auto-scan.  

65534 TIMEZONE UDP Multicast MOBA-NMS Time zone monitor 
  

http://www.java.com/en/download
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